packaged the atd daemon
[openwrt/svn-archive/archive.git] / ipv6 / mrd6 / Makefile
index 49f72234a866712acd31a54230347c70eb098183..a843e72b34ba58506e38cd46336941e7850fd022 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,57 +10,63 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mrd6
 PKG_VERSION:=0.9.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
+PKG_REVISION:=3
+PKG_RELEASE:=$(PKG_REVISION).1
 
-PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION).tar.gz
+PKG_SOURCE_URL:=http://fivebits.net/files/mrd6/ \
+       http://hng.av.it.pt/mrd6/download/
+PKG_MD5SUM:=361322198dafcc5ffab5e8e23197012b
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-PKG_BUILDDEP:=libnotimpl
+PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mrd6
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+uclibcxx
   TITLE:=IPv6 multicast routing daemon
-  DESCRIPTION:=Multicast is becoming a major component in next generation\\\
-               networks, used in several scenarios, from video broadcasting\\\
-               to multimedia conferencing. In order to be implemented, new\\\
-               technology needs supporting hardware and software across a set\\\
-               of devices and systems. MRD6 is an implementation of a modular\\\
-               IPv6 Multicast Routing Framework for the Linux operating system\\\
-               and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.\\\
   URL:=http://artemis.av.it.pt/mrd6/
+  DEPENDS:= +uclibcxx
 endef
 
-define Package/mrd6/conffiles
-/etc/mrd6.conf
+define Package/mrd6/description
+ Multicast is becoming a major component in next generation networks, used 
+ in several scenarios, from video broadcasting to multimedia conferencing. 
+ In order to be implemented, new technology needs supporting hardware and 
+ software across a set of devices and systems. MRD6 is an implementation of 
+ a modular IPv6 Multicast Routing Framework for the Linux operating system 
+ and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.
 endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
+               $(TARGET_CONFIGURE_OPTS) \
                OPTIMIZE=yes \
                SPACE_OPTIMIZE=yes \
-               FULL_STATIC=yes \
-               CFLAGS="$(TARGET_CFLAGS) -DNO_INET6_OPTION" \
-               CXX="$(TARGET_CROSS)g++" \
-               CC="$(TARGET_CC)" \
-               STAGING_DIR="$(STAGING_DIR)" \
+               FULL_STATIC=no \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DNO_INET6_OPTION -fno-builtin -fno-rtti" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -ldl -lgcc -lm -lnotimpl" \
+               MODULE_CXX="\$$$$(CC) -shared \$$$$(CXXFLAGS) \$$$$(LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               PREFIX=/usr/ \
+               PREFIX="/usr" \
                install
 endef
 
+define Package/mrd6/conffiles
+/etc/mrd6.conf
+endef
+
 define Package/mrd6/install
-       install -d -m0755 $(1)/etc/init.d
-       install -m0644 files/mrd6.conf $(1)/etc
-       install -m0755 files/mrd6.init $(1)/etc/init.d/mrd6
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DATA) files/mrd6.conf $(1)/etc
+       $(INSTALL_BIN) files/mrd6.init $(1)/etc/init.d/mrd6
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mrd $(1)/usr/sbin/mrd6
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mrd6sh $(1)/usr/bin/mrd6sh
+       $(INSTALL_DIR) $(1)/usr/lib/mrd6
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/mrd6/bgp.so $(1)/usr/lib/mrd6/bgp.so
 endef
 
 $(eval $(call BuildPackage,mrd6))