mrd6: remove invasive stuff from patch 001 and rename it, Makefile cleanup
[openwrt/svn-archive/archive.git] / ipv6 / mrd6 / Makefile
index 0895f80544ad8f62d829a3796e0eecca2a2ec971..e4d99415acd27306ecc67bfefbc84acfaf703081 100644 (file)
@@ -11,16 +11,12 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=mrd6
 PKG_VERSION:=0.9.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
 
 PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
 
-PKG_BUILDDEP:=libnotimpl
+PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,13 +25,6 @@ define Package/mrd6
   CATEGORY:=IPv6
   DEPENDS:=@LINUX_2_6 +uclibcxx
   TITLE:=IPv6 multicast routing daemon
-  DESCRIPTION:=Multicast is becoming a major component in next generation\\\
-               networks, used in several scenarios, from video broadcasting\\\
-               to multimedia conferencing. In order to be implemented, new\\\
-               technology needs supporting hardware and software across a set\\\
-               of devices and systems. MRD6 is an implementation of a modular\\\
-               IPv6 Multicast Routing Framework for the Linux operating system\\\
-               and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.\\\
   URL:=http://artemis.av.it.pt/mrd6/
 endef
 
@@ -43,17 +32,26 @@ define Package/mrd6/conffiles
 /etc/mrd6.conf
 endef
 
+define Package/mrd6/description
+ Multicast is becoming a major component in next generation networks, used 
+ in several scenarios, from video broadcasting to multimedia conferencing. 
+ In order to be implemented, new technology needs supporting hardware and 
+ software across a set of devices and systems. MRD6 is an implementation of 
+ a modular IPv6 Multicast Routing Framework for the Linux operating system 
+ and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.
+endef
+
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
+               $(TARGET_CONFIGURE_OPTS) \
                OPTIMIZE=yes \
                SPACE_OPTIMIZE=yes \
-               FULL_STATIC=yes \
-               CFLAGS="$(TARGET_CFLAGS) -DNO_INET6_OPTION" \
-               CXX="$(TARGET_CROSS)g++" \
-               CC="$(TARGET_CC)" \
-               STAGING_DIR="$(STAGING_DIR)" \
+               FULL_STATIC=no \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DNO_INET6_OPTION -fno-builtin -fno-rtti" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -ldl -lm -lnotimpl" \
+               MODULE_CXX="\$$$$(CC) -shared \$$$$(CXXFLAGS) \$$$$(LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               PREFIX=/usr/ \
+               PREFIX="/usr/" \
                install
 endef
 
@@ -61,6 +59,12 @@ define Package/mrd6/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DATA) files/mrd6.conf $(1)/etc
        $(INSTALL_BIN) files/mrd6.init $(1)/etc/init.d/mrd6
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mrd $(1)/usr/sbin/mrd6
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mrd6sh $(1)/usr/bin/mrd6sh
+       $(INSTALL_DIR) $(1)/usr/lib/mrd6
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/mrd6/bgp.so $(1)/usr/lib/mrd6/bgp.so
 endef
 
 $(eval $(call BuildPackage,mrd6))