[packages] radvd: bump to v1.8 - solves size regression (#9733)
[openwrt/svn-archive/archive.git] / ipv6 / radvd / Makefile
index 39b11e16595ae3b24ac9f3399b0132513e7f40f5..e40a1102b1ed3449b56145334fa5fdd98a619ae0 100644 (file)
@@ -1,22 +1,22 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
-PKG_VERSION:=1.1
+PKG_VERSION:=1.8
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
                http://download.sourcemage.org/mirror
-PKG_MD5SUM:=9ee449e4b89171432cb9e9100e0b5648
+PKG_MD5SUM:=50b4cfbdfa04d629d80437fd1d9e2aef
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,51 +25,17 @@ define Package/radvd
   CATEGORY:=IPv6
   TITLE:=IPv6 Routing Advertisement Daemon
   URL:=http://v6web.litech.org/radvd/
+  DEPENDS:=+kmod-ipv6
 endef
 
 define Package/radvd/description
 IPv6 Routing Advertisement Daemon.
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --with-configfile=/etc/radvd.conf \
-                       --with-logfile=/var/log/radvd.log \
-                       --with-pidfile=/var/run/radvd.pid \
-       );
-endef
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               radvd_LDADD=""
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
-endef
+CONFIGURE_ARGS += \
+       --with-configfile=/etc/radvd.conf \
+       --with-logfile=/var/log/radvd.log \
+       --with-pidfile=/var/run/radvd.pid
 
 define Package/radvd/conffiles
 /etc/config/radvd
@@ -77,7 +43,7 @@ endef
 
 define Package/radvd/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/radvd.config $(1)/etc/config/radvd
+       $(INSTALL_CONF) ./files/radvd.config $(1)/etc/config/radvd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/radvd.init $(1)/etc/init.d/radvd
        $(INSTALL_DIR) $(1)/usr/sbin