Bump radvd to 1.2, cleanup makefile (#4230)
[openwrt/svn-archive/archive.git] / ipv6 / radvd / Makefile
index 39b11e16595ae3b24ac9f3399b0132513e7f40f5..e51b963d58eba5e46da3c3baf1e0963098cf0d39 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
-PKG_VERSION:=1.1
+PKG_VERSION:=1.2
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
                http://download.sourcemage.org/mirror
-PKG_MD5SUM:=9ee449e4b89171432cb9e9100e0b5648
+PKG_MD5SUM:=614876420d76cd2bb5bcb49760c8b9e3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,38 +32,14 @@ IPv6 Routing Advertisement Daemon.
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --with-configfile=/etc/radvd.conf \
-                       --with-logfile=/var/log/radvd.log \
-                       --with-pidfile=/var/run/radvd.pid \
-       );
+       $(call Build/Configure/Default,\
+               --with-configfile=/etc/radvd.conf \
+               --with-logfile=/var/log/radvd.log \
+               --with-pidfile=/var/run/radvd.pid \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                radvd_LDADD=""
        $(MAKE) -C $(PKG_BUILD_DIR) \