added <python> as build dependency, because <python-core> as regular dependency can...
[openwrt/svn-archive/archive.git] / lang / cython / Makefile
index bccaec14aecf882493096166d4a68a2305d3dd9c..29e60ed2e37a5624059d4e40296520dec030e6dc 100644 (file)
@@ -15,6 +15,8 @@ PKG_SOURCE:=Cython-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.cython.org/
 PKG_BUILD_DIR:=$(BUILD_DIR)/Cython-$(PKG_VERSION)
 
+PKG_BUILD_DEPENDS:=python
+
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
@@ -24,7 +26,7 @@ define Package/cython
   CATEGORY:=Languages
   TITLE:=cython
   URL:=http://www.cython.org
-  DEPENDS:=python-core @BROKEN
+  DEPENDS:=python-core
 endef
 
 define Package/cython/description
@@ -32,7 +34,8 @@ define Package/cython/description
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+       # <--no-cython-compile> required, otherwise setup.py calls the target-gcc to create so-files which obviously can't be used by <python> on the host system.
+       $(call Build/Compile/PyMod,,install --no-cython-compile --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Build/InstallDev