python packages cleanup, add some missing deps
[openwrt/svn-archive/archive.git] / lang / egenix-mx / Makefile
index 2c9e0b1f1881e715939a9230e9406cf2b8d87223..35bdcf09914b36f9503bb99e16bda8cb2a04cb2b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,7 +13,7 @@ PKG_VERSION:=2.0.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-base-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.egenix.com/files/python/
+PKG_SOURCE_URL:=http://downloads.egenix.com/python/
 PKG_MD5SUM:=66841151728a06f92d0b8dd2ed317a29
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-base-$(PKG_VERSION)
@@ -21,11 +21,9 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
-endif
 
 define Package/python-egenix-mx
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   DEPENDS:=python-core
@@ -39,6 +37,7 @@ define Package/python-egenix-mx/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --build-lib="foo", \
                BASECFLAGS="$(TARGET_CFLAGS)" \
@@ -82,10 +81,6 @@ define Build/InstallDev
                $(1)$(PYTHON_PKG_DIR)/mx/Tools/mxTools/
 endef
 
-define Build/UninstallDev
-       rm -rf $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx
-endef
-
 define PyPackage/python-egenix-mx/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) $(PKG_BUILD_DIR)/foo/mx $(1)$(PYTHON_PKG_DIR)/