move in Python submenu, misc cosmetic changes
[openwrt/svn-archive/archive.git] / lang / egenix-mx / Makefile
index efd4abadc5705d61123baa1c466f607d11b7ea7b..7e5001b2a62fbfdc889f527b8a8090c915bc88a5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,20 +13,28 @@ PKG_VERSION:=2.0.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-base-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.egenix.com/files/python/
+PKG_SOURCE_URL:=http://downloads.egenix.com/python/
 PKG_MD5SUM:=66841151728a06f92d0b8dd2ed317a29
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-base-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
+endif
 
-define PyPackage/egenix-mx
- TITLE:=Egenix mxBase
- URL:=http://www.egenix.com/products/python/mxBase/
+define Package/python-egenix-mx
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  DEPENDS:=python-core
+  TITLE:=Egenix mxBase
+  URL:=http://www.egenix.com/products/python/mxBase/
 endef
 
-define PyPackage/egenix-mx/description
+define Package/python-egenix-mx/description
  This package contains a set of base packages from Egenix required by other 
  python packages.
 endef
@@ -75,11 +83,7 @@ define Build/InstallDev
                $(1)$(PYTHON_PKG_DIR)/mx/Tools/mxTools/
 endef
 
-define Build/UninstallDev
-       rm -rf $(STAGING_DIR)$(PYTHON_PKG_DIR)/mx
-endef
-
-define PyPackage/egenix-mx/install
+define PyPackage/python-egenix-mx/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) $(PKG_BUILD_DIR)/foo/mx $(1)$(PYTHON_PKG_DIR)/
        ln -sf  $(1)$(PYTHON_PKG_DIR)/mx/BeeBase/ExitFunctions.py \
@@ -87,4 +91,5 @@ define PyPackage/egenix-mx/install
        rm -rf  $(1)$(PYTHON_PKG_DIR)/mx/*/Examples
 endef
 
-$(eval $(call PyPackage,egenix-mx))
+$(eval $(call PyPackage,python-egenix-mx))
+$(eval $(call BuildPackage,python-egenix-mx))