move jamvm & sablevm in 'Java' submenu, move descriptions in separate defs, cleanup
[openwrt/svn-archive/archive.git] / lang / jamvm / Makefile
index 4dbd921aea95d7adcedb0197a89c25f8509d9633..3d544dc696839875728bdd87af5e685b1933436f 100644 (file)
@@ -9,50 +9,49 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=jamvm
-PKG_VERSION:=1.4.1
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/jamvm
-PKG_MD5SUM:=ed79d6b60e50b007614831f8c28321ac
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=1b7bc9928c534412e062685a4191651d
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/jamvm
+  SUBMENU:=Java
   SECTION:=lang
   CATEGORY:=Languages
-  DEPENDS:=+libffi-sable
   TITLE:=A compact Java Virtual Machine
-  DESCRIPTION:=\
-       JamVM is a new Java Virtual Machine which conforms to the JVM \\\
-       specification version (blue book). In comparison to most other VM's \\\
-       (free and commercial) it is extremely small.However, unlike other \\\
-       small VMs (e.g. KVM) it is designed to support the full \\\
-       specification, and includes support for object finalisation, \\\
-       Soft/Weak/Phantom References, the Java Native Interface (JNI) and the \\\
-       Reflection API.
   URL:=http://sourceforge.net/projects/jamvm
+  DEPENDS:=+libffi-sable @!mips
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-ffi \
-       )
+define Package/jamvm/description
+ JamVM is a new Java Virtual Machine which conforms to the JVM 
+ specification version (blue book). In comparison to most other VM's (free 
+ and commercial) it is extremely small.However, unlike other small VMs 
+ (e.g. KVM) it is designed to support the full specification, and includes 
+ support for object finalisation, Soft/Weak/Phantom References, the Java 
+ Native Interface (JNI) and the Reflection API.
 endef
 
+CONFIGURE_ARGS+= \
+       --enable-ffi \
+       --disable-int-threading \
+
 define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-              $(TARGET_CONFIGURE_OPTS)
+       $(MAKE) -C $(PKG_BUILD_DIR) all
 endef
 
-define Package/jamvm/install   
+ifneq ($(ARCH),mips)
+  define Package/jamvm/install 
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/jamvm $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share/jamvm
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/lib/classes.zip $(1)/usr/share/jamvm/
-endef
+  endef
+endif
 
 $(eval $(call BuildPackage,jamvm))
+