fix jamvm compile on mips (#1031)
[openwrt/svn-archive/archive.git] / lang / jamvm / patches / 100-jamvm-mips.patch
index 8feebc4f7aa2fd7f4f9713754653ceb50dedc53c..960dc6ed8fba06d10be1112990c7ebe218e0e827 100644 (file)
@@ -68,7 +68,7 @@ diff -urN jamvm-1.4.0-orig/src/arch/Makefile.in jamvm-1.4.0/src/arch/Makefile.in
 diff -urN jamvm-1.4.0-orig/src/arch/mips.h jamvm-1.4.0/src/arch/mips.h
 --- jamvm-1.4.0-orig/src/arch/mips.h   1970-01-01 01:00:00.000000000 +0100
 +++ jamvm-1.4.0/src/arch/mips.h        2005-11-29 22:31:08.000000000 +0100
-@@ -0,0 +1,70 @@
+@@ -0,0 +1,69 @@
 +/*
 + * Copyright (C) 2003, 2004, 2005 Robert Lougher <rob@lougher.demon.co.uk>.
 + *
@@ -92,7 +92,6 @@ diff -urN jamvm-1.4.0-orig/src/arch/mips.h jamvm-1.4.0/src/arch/mips.h
 +#define OS_ARCH "mips"
 +
 +#include <bits/atomicity.h>
-+#include <asm/atomic.h>
 +
 +/* Override default min and max heap sizes.  mips machines are
 +   usually embedded, and the standard defaults are too large. */