[package] input-utils: update to make it works with new kernels.
[openwrt/svn-archive/archive.git] / lang / kid / Makefile
index 663a9bb7e0799664adcdf5fd3e42da045209396b..252c6f10a5c86f494a5de01c7021b1942e9c3106 100644 (file)
@@ -1,11 +1,10 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kid
@@ -16,15 +15,21 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kid-templating.org/dist/0.9.6/dist
 PKG_MD5SUM:=31e7156698a6f214b4067afb9e13728f
 
-include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
+PKG_BUILD_DEPENDS:=python
 
-define PyPackage/python-kid
- TITLE:=XML-based Templating
- URL=http://www.kid-templating.org/
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-kid
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  DEPENDS:=+python
+  TITLE:=XML-based Templating
+  URL:=http://www.kid-templating.org/
 endef
 
-define PyPackage/python-kid/description
+define Package/python-kid/description
  Kid is a simple template language for XML based vocabularies written in 
  Python.
 endef
@@ -35,9 +40,11 @@ define PyPackage/python-kid/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
 endef
 
 $(eval $(call PyPackage,python-kid))
+$(eval $(call BuildPackage,python-kid))