fix logilab-astng and logilab-common compile
[openwrt/svn-archive/archive.git] / lang / logilab-common / Makefile
index 5e69a5840566528a9bf8cda96c09660378c0aff7..2fdce18c1f74cbb86b1ff188d218eafcac8d9513 100644 (file)
@@ -15,9 +15,6 @@ PKG_SOURCE_URL:=ftp://ftp.logilab.fr/pub/common/
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/logilab-common
   SUBMENU:=Python
@@ -25,7 +22,7 @@ define Package/logilab-common
   CATEGORY:=Languages
   TITLE:=logilab-common
   URL:=http://www.logilab.fr
-  DEPENDS:=python-core 
+  DEPENDS:=+python-mini
 endef
 
 define Package/logilab-common/description
@@ -33,15 +30,15 @@ define Package/logilab-common/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
 endef
 
-define Package/logilad-common/install
+define Package/logilab-common/install
        mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
-$(eval $(call PyPackage,logilab-common))
 $(eval $(call BuildPackage,logilab-common))