[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / lang / luafilesystem / Makefile
index 945d263facf7cf4a866b84dd8c8e4627d2a3f328..d9dbea08b7e6aab6bf78efb02dea9b8887b97a6c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,16 +18,16 @@ PKG_MD5SUM:=fe2fa6decc48f0267b4f09975750280e
 include $(INCLUDE_DIR)/package.mk
 
 define Package/liblua-filesystem
-  SUBMENU:=LUA
+  SUBMENU:=Lua
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=luafilsystem - library for the LUA programming language
+  TITLE:=LuaFileSystem
   URL:=http://www.luaforge.net/projects/luafilesystem
   DEPENDS:=+liblua
 endef
 
 define Package/luafilesystem/description
- This package contains the luafilesystem library, a set of portable
+ This package contains the LuaFileSystem library, a set of portable
  functions for directory creation, listing and deletion and for file
  locking.
 endef
@@ -35,8 +35,7 @@ endef
 define Build/Configure
 endef
 
-TARGET_CFLAGS += $(FPIC) \
-       -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += $(FPIC) $(TARGET_CPPFLAGS)
 
 TARGET_LDFLAGS += -llua