[packages] urbi, opensips, faifa, kamailio: Build with -fPIC
[openwrt/svn-archive/archive.git] / lang / luaprofiler / Makefile
index 104a3bc3438aafbbda3a9a1f2dc01a432a16b875..1ecc69447515a8685a8603909c6325bfbba5d2d9 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,11 +18,12 @@ PKG_MD5SUM:=611435c8e61e1a330ee0aa8ddc9c124a
 include $(INCLUDE_DIR)/package.mk
 
 define Package/luaprofiler
-  SUBMENU:=LUA
+  SUBMENU:=Lua
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Lua Profiler
   URL:=http://luaprofiler.luaforge.net
+  DEPENDS:=+lua
 endef
 
 define Package/luaprofiler/description
@@ -33,15 +34,14 @@ define Build/Configure
 
 endef
 
-TARGET_CFLAGS += $(FPIC) \
-       -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += $(FPIC) $(TARGET_CPPFLAGS)
 
 TARGET_LDFLAGS += -llua
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -std=gnu99" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                -f Makefile.linux
 endef