Allow compilation on >=2.6.30
[openwrt/svn-archive/archive.git] / lang / luaprofiler / Makefile
index c7fa5b1ae310120a23dcb4a0204a13d1d1a6a868..3b815315d8681fea80799af23a978a9bc8826b46 100644 (file)
@@ -23,6 +23,7 @@ define Package/luaprofiler
   CATEGORY:=Languages
   TITLE:=Lua Profiler
   URL:=http://luaprofiler.luaforge.net
+  DEPENDS:=+lua
 endef
 
 define Package/luaprofiler/description
@@ -33,8 +34,7 @@ define Build/Configure
 
 endef
 
-TARGET_CFLAGS += $(FPIC) \
-       -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += $(FPIC) $(TARGET_CPPFLAGS)
 
 TARGET_LDFLAGS += -llua