[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / lang / luasocket / Makefile
index bc414934054ea2746ab99200c33d4c64a647f3e2..d2673c2458f3590b3bd6b6a898341b25e097afcf 100644 (file)
@@ -37,8 +37,8 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/ all \
-       LIBDIR="-L$(STAGING_DIR)/usr/lib/" \
-       CC="$(TARGET_CC) $(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       LIBDIR="$(TARGET_LDFLAGS)" \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LD="$(TARGET_CROSS)ld -shared" 
 endef