[packages] Xorg/apps/xdm: add missing libX11 libXmu libXau and libXaw deps
[openwrt/svn-archive/archive.git] / lang / numpy / Makefile
index b2a321336c7356b512bcf752e21f03e0e3921678..a99b5f5fb784da00ff55bafe849eb2751a684260 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,8 +12,10 @@ PKG_VERSION:=1.0.4
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.sourceforge.net/numpy/
+PKG_MD5SUM:=8f011e9d7697da570efaac61c51725e0
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 define Package/numpy
   SUBMENU:=Python
@@ -21,7 +23,7 @@ define Package/numpy
   CATEGORY:=Languages
   TITLE:=numpy
   URL:=http://numpy.sf.net
-  DEPENDS:=python-core
+  DEPENDS:=+python-mini @TARGET_x86||TARGET_olpc||TARGET_uml @BROKEN
 endef
 
 define Package/numpy/description
@@ -29,8 +31,7 @@ define Package/numpy/description
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) /usr/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
-       sed -i "s/UCS4/UCS2/g" $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/numpy/core/multiarray.so
+       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) python2.5 ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
 endef
 
 define Package/numpy/install
@@ -38,4 +39,13 @@ define Package/numpy/install
        cp -r $(PKG_INSTALL_DIR)/* $(1)
 endef
 
+define Require/python25-dev
+[ -e /usr/include/python2.5/pyconfig.h ]
+endef
+
+$(eval $(call Require,python25-dev, \
+       Please install Python 2.5 (including development headers and libraries) \
+))
+
 $(eval $(call BuildPackage,numpy))
+