[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / lang / perl / Makefile
index 8e409d2e25ae1ef69d60d202c38772e0c7ec596e..57104f9cd398c50becb68277941c6ad34d467ebb 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -102,14 +101,14 @@ define Build/perl/Configure
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
        sed \
                -e 's!%%CC%%!$(TARGET_CC)!g' \
-               -e 's!%%CFLAGS%%!$(TARGET_CFLAGS) -DUSE_CROSS_COMPILE -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include!g' \
+               -e 's!%%CFLAGS%%!$(TARGET_CFLAGS) -DUSE_CROSS_COMPILE $(TARGET_CPPFLAGS)!g' \
                -e 's!%%CPP%%!$(TARGET_CROSS)gcc -E!g' \
                -e 's!%%AR%%!$(TARGET_CROSS)ar!g' \
                -e 's!%%LD%%!$(TARGET_CROSS)gcc!g' \
-               -e 's!%%LDFLAGS%%!-rdynamic -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib!g' \
+               -e 's!%%LDFLAGS%%!-rdynamic $(TARGET_LDFLAGS)!g' \
                -e 's!%%LIBDIRS%%!$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib!g' \
                -e 's!%%INCDIRS%%!$(STAGING_DIR)/include $(STAGING_DIR)/usr/include!g' \
-               files/config.sh-$(REAL_GNU_TARGET_NAME).in \
+               files/config.sh-$(patsubst i386,i486,$(ARCH)).in \
                > $(PKG_BUILD_DIR)/config.sh
        (cd $(PKG_BUILD_DIR) && ./Configure -S)
 endef
@@ -179,6 +178,12 @@ endef
 endif
 $(eval $(Build/perl))
 
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
 $(eval $(call BuildPackage,microperl))
 $(eval $(call BuildPackage,perl))