upgrade miniupnpd to 1.0-RC3
[openwrt/svn-archive/archive.git] / lang / perl / Makefile
index 936b1497ec13fdd7909dc3ce0833b7a429253db8..de6083639b359ed1f19d1ca86ac6f4b4ad4da44c 100644 (file)
@@ -12,7 +12,6 @@ PKG_NAME:=perl
 PKG_VERSION:=5.8.6
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.cpan.org/pub/CPAN/src/5.0 \
                ftp://ftp.mpi-sb.mpg.de/pub/perl/CPAN/src/5.0 \
@@ -21,14 +20,16 @@ PKG_SOURCE_URL:=ftp://ftp.cpan.org/pub/CPAN/src/5.0 \
 PKG_MD5SUM:=8d4aa4e061fd5bc0c39e4f0a63267880
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/microperl
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=A really minimal perl
-  DESCRIPTION:=A really minimal perl.\\\
-    A perl package without operating-specific functions such as readdir.
+  DESCRIPTION:=\
+       A perl package without operating-specific functions such as readdir.
   URL:=http://www.perl.com/
 endef
 
@@ -41,8 +42,8 @@ define Build/Compile
 endef
 
 define Package/microperl/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/microperl $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/microperl $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,microperl))