fix php4 compile on arm, add fpic while we're at it
[openwrt/svn-archive/archive.git] / lang / php4 / Makefile
index f8cef7915d299f283a87d8c1ffc52217e451138e..5c8bab0512c8785871117538661bdf71f4b74a53 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006,2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,11 +24,12 @@ define Package/php4/Default
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PHP4 Hypertext preprocessor
+  DEPENDS:=@!TARGET_ixp4xx
   URL:=http://www.php.net/
 endef
 
 define Package/php4/Default/description
- PHP is a widely-used general-purpose scripting language that is especially 
+ PHP is a widely-used general-purpose scripting language that is especially
  suited for Web development and can be embedded into HTML.
 endef
 
@@ -39,7 +40,7 @@ endef
 
 define Package/php4/description
 $(call Package/php4/Default/description)
- This package contains only the PHP config file. You must actually choose 
+ This package contains only the PHP config file. You must actually choose
  your PHP flavour (cli, cgi or fastcgi).
 endef
 
@@ -249,6 +250,8 @@ endif
 define Build/Configure
 endef
 
+TARGET_CFLAGS += $(if $(CONFIG_BIG_ENDIAN),-DIEEE_BIG_ENDIAN,-DIEEE_LITTLE_ENDIAN) $(FPIC)
+
 ifneq ($(CONFIG_PACKAGE_php4-cli),)
   define Build/Compile/php4-cli
        -$(MAKE) -C $(PKG_BUILD_DIR) clean