[package] php5: add missing dependency on libsqlite3/libpthread (#7224)
[openwrt/svn-archive/archive.git] / lang / php5 / Makefile
index 4bb2180ad4bbc7ad27383bd53b69ea4af675a0bb..8022f63154d39f3e924ad4cbb165573bf476707b 100644 (file)
@@ -54,6 +54,9 @@ define Package/php5
   ifneq ($(CONFIG_PHP5_LIBXML),)
     DEPENDS+= +libxml2
   endif
+  ifneq ($(CONFIG_PACKAGE_php5-mod-sqlite3)$(CONFIG_PACKAGE_php5-mod-pdo-sqlite),)
+    DEPENDS+= +libsqlite3 +libpthread
+  endif
 endef
 
 define Package/php5/description