prevent procps from looking for ncurses on the host system
[openwrt/svn-archive/archive.git] / lang / php5 / Makefile
index fd82f479c0d44449b561cc2aff014a2144966825..929099f49ba48c1422d4e03a93d8b0c8066c30a0 100644 (file)
@@ -186,7 +186,7 @@ PKG_CONFIGURE_OPTS:= \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
 
 ifneq ($(SDK),)
-  PKG_BUILDDEP:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libexpat
+  PKG_BUILD_DEPENDS:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libexpat
 # force PKG_CONFIGURE_{LIBS,OPTS} below when built in the SDK
   CONFIG_PACKAGE_php5-cli:=m
   CONFIG_PACKAGE_php5-cgi:=m
@@ -325,32 +325,32 @@ define Build/Compile
 endef
 
 define Package/php5/install
-       install -m0755 -d $(1)/etc
-       install -m0644 ./files/php.ini $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/php.ini $(1)/etc/
 endef
 
 define Package/php5-cli/install
-       install -m0755 -d $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/php-cli $(1)/usr/bin/php
 endef
 
 define Package/php5-cgi/install
-       install -m0755 -d $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/php-cgi $(1)/usr/bin/php
 endef
 
 define Package/php5-fastcgi/install
-       install -m0755 -d $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/php-fastcgi $(1)/usr/sbin/php
-       install -m0755 -d $(1)/etc/init.d
-       install -m0755 ./files/php.init $(1)/etc/init.d/php
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/php.init $(1)/etc/init.d/php
 endef
 
 define BuildPlugin
   define Package/$(1)/install
-       [ -z "$(2)" ] || install -d -m0755 $$(1)/usr/lib/php
+       [ -z "$(2)" ] || $(INSTALL_DIR) $$(1)/usr/lib/php
        for m in $(2); do \
-               install -m0755 $(PKG_BUILD_DIR)/modules/$$$$$$$${m}.so $$(1)/usr/lib/php/ ; \
+               $(INSTALL_BIN) $(PKG_BUILD_DIR)/modules/$$$$$$$${m}.so $$(1)/usr/lib/php/ ; \
        done
   endef