[PATCH] php5: Php's sqlite3 module needs to be explicite linked to -lpthread with...
[openwrt/svn-archive/archive.git] / lang / php5 / Makefile
index aa1067e1b9c03c4d8779a3e1c1f759fee22a0e76..fd84461a3b9c3693b3b0b0840b8b52b5fe493c60 100644 (file)
@@ -266,7 +266,7 @@ endef
 
 define Package/php5-mod-pdo-sqlite
   $(call Package/php5/Default)
-  DEPENDS:=php5-mod-pdo +libsqlite3
+  DEPENDS:=php5-mod-pdo +libsqlite3 +libpthread
   TITLE:=PDO driver for SQLite (3.x)
 endef
 
@@ -318,7 +318,7 @@ endef
 
 define Package/php5-mod-sqlite3
   $(call Package/php5/Default)
-  DEPENDS:=php5 +libsqlite3
+  DEPENDS:=php5 +libsqlite3 +libpthread
   TITLE:=SQLite3 shared module (3.x)
 endef
 define Package/php5-mod-sqlite3/config
@@ -390,7 +390,7 @@ PKG_CONFIGURE_OPTS:= \
        --disable-phar
 
 ifneq ($(SDK),)
-  PKG_BUILD_DEPENDS:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libsqlite3 libpcre libxml2
+  PKG_BUILD_DEPENDS:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libpthread libsqlite3 libpcre libxml2
 # force PKG_CONFIGURE_{LIBS,OPTS} below when built in the SDK
   CONFIG_PACKAGE_php5-cli:=m
   CONFIG_PACKAGE_php5-cgi:=m
@@ -527,7 +527,7 @@ ifneq ($(CONFIG_PACKAGE_php5-mod-pdo),)
   endif
   ifneq ($(CONFIG_PACKAGE_php5-mod-pdo-sqlite),)
     PKG_CONFIGURE_OPTS+= --with-pdo-sqlite=shared,"$(STAGING_DIR)/usr"
-    PKG_CONFIGURE_LIBS+= -lsqlite3
+    PKG_CONFIGURE_LIBS+= -lsqlite3 -lpthread
   else
     PKG_CONFIGURE_OPTS+= --without-pdo-sqlite
   endif
@@ -567,7 +567,7 @@ endif
 
 ifneq ($(CONFIG_PACKAGE_php5-mod-sqlite3),)
   PKG_CONFIGURE_OPTS+= --with-sqlite3=shared,"$(STAGING_DIR)/usr"
-  PKG_CONFIGURE_LIBS+= -lsqlite3
+  PKG_CONFIGURE_LIBS+= -lsqlite3 -lpthread
 else
   PKG_CONFIGURE_OPTS+= --without-sqlite3
 endif