xkbdata: Add missing dependency to xkbcomp
[openwrt/svn-archive/archive.git] / lang / psycopg / Makefile
index f4060568f6f642833b80fbdbf752edd4753491cc..4cb605145f5bba6a1581524ef63af8710f35a1b5 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,7 +18,7 @@ PKG_MD5SUM:=a31f79f68d6d32898d6f24e11369a106
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/python-psycopg
   SUBMENU:=Python
@@ -27,7 +26,7 @@ define Package/python-psycopg
   CATEGORY:=Languages
   TITLE:=PostgreSQL database adapter for Python
   URL:=http://www.initd.org/
-  DEPENDS:=python-core +libpq +python-egenix-mx
+  DEPENDS:=+python-mini +libpq +python-egenix-mx
 endef
 
 define Package/python-psycopg/description
@@ -40,6 +39,8 @@ CONFIGURE_ARGS += \
        --with-postgres-libraries="$(STAGING_DIR)/usr/lib" \
        --with-postgres-includes="$(STAGING_DIR)/usr/include" \
        --with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
+       --with-python-prefix=$(STAGING_DIR)/usr
+       --with-python-exec-prefix=$(STAGING_DIR)/usr
 
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)