remove a few obsolete dependencies now that dependency propagation is fixed
[openwrt/svn-archive/archive.git] / lang / pycairo / Makefile
index 84f07aac09ad2871ad72d1326438748f7ced371b..4d92827150ca493d2334876d974f839418600b3d 100644 (file)
@@ -12,17 +12,15 @@ PKG_VERSION:=1.4.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.cairographics.org/releases/
-#PKG_MD5SUM:=532268f02870bea18c1d465e88afff30
+PKG_SOURCE_URL:=http://www.cairographics.org/releases
 PKG_BUILD_DEPENDS:=python cairo
+PKG_FIXUP:=libtool
+PKG_MD5SUM:=c63199d35b1e1d3c5133509f315f70d7
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/pycairo
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Cairo bindings to python
@@ -34,11 +32,29 @@ define Package/pycairo/description
   cairo modul for python
 endef
 
-define Build/Compile
-       $(call Build/Compile/PyMod,., \
-               install --prefix="$(PKG_INSTALL_DIR)/usr", \
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
        )
 endef
 
-$(eval $(call PyPackage,pycairo))
+define Build/Compile
+       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+define Package/pycairo/install
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
 $(eval $(call BuildPackage,pycairo))