ettercap: Fix parallel build
[openwrt/svn-archive/archive.git] / lang / pyevent / Makefile
index 0492a2569f61fada71c1f77f513e586064a9fbbc..26cadf29e58ea77ee7242847df6acc026383b9ca 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,13 +15,18 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pyevent.googlecode.com/files/
 PKG_MD5SUM:=584912c92d08bf005283fb29a47a6e4d
 
-include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
+PKG_BUILD_DEPENDS:=python
 
-define PyPackage/python-event
- TITLE:=Python interface to libevent
- URL=http://code.google.com/p/pyevent/
- DEPENDS+= +libevent
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-event
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Python interface to libevent
+  URL:=http://code.google.com/p/pyevent/
+  DEPENDS:=+python-mini +libevent
 endef
 
 define PyPackage/python-event/filespec
@@ -30,10 +34,12 @@ define PyPackage/python-event/filespec
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,., \
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                LIBEVENT_HOME="$(STAGING_DIR)/usr/lib" \
        )
 endef
 
 $(eval $(call PyPackage,python-event))
+$(eval $(call BuildPackage,python-event))