xkbdata: Add missing dependency to xkbcomp
[openwrt/svn-archive/archive.git] / lang / pygobject / Makefile
index 066431754b173390afd4b775f52f6d4e8557d1b6..7114325ca8ba5b040d5ae01dd4b7b784078fde07 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,19 +18,21 @@ PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 EXTRA_LDFLAGS+= \
        -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
        -L$(STAGING_DIR)/usr/lib/libiconv/lib/
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/python-gobject
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=GLib bindings for python
   URL:=http://www.pygtk.org/
-  DEPENDS:=python-core +glib2
+  DEPENDS:=+python-mini +glib2 +libffi
 endef
 
 define Package/python-gobject/description