xkbdata: Add missing dependency to xkbcomp
[openwrt/svn-archive/archive.git] / lang / pygobject / Makefile
index c0995c5d5025c0cc027c94cbdad8aa9f44cc70de..7114325ca8ba5b040d5ae01dd4b7b784078fde07 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,12 +18,14 @@ PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 EXTRA_LDFLAGS+= \
        -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
        -L$(STAGING_DIR)/usr/lib/libiconv/lib/
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/python-gobject
   SUBMENU:=Python
   SECTION:=lang