python packages cleanup, add some missing deps
[openwrt/svn-archive/archive.git] / lang / pymysql / Makefile
index d1bd2bff5ef18667fc99dba1120c3f4458f44562..8b0486a8dafde77cc9c2cfaf02248fcb0ea45933 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,16 +16,21 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mysql-python
 PKG_MD5SUM:=532268f02870bea18c1d465e88afff30
 
-include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
+PKG_BUILD_DEPENDS:=python
 
-define PyPackage/python-mysql
- TITLE:=MySQL database adapter for Python
- URL:=http://mysql-python.sourceforge.net/
- DEPENDS+= +libmysqlclient
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-mysql
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=MySQL database adapter for Python
+  URL:=http://mysql-python.sourceforge.net/
+  DEPENDS:=python-core +libmysqlclient
 endef
 
-define PyPackage/python-mysql/description
+define Package/python-mysql/description
  MySQLdb is an thread-compatible interface to the popular MySQL database 
  server that provides the Python database API.
 endef
@@ -37,9 +42,11 @@ define PyPackage/python-mysql/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
 endef
 
 $(eval $(call PyPackage,python-mysql))
+$(eval $(call BuildPackage,python-mysql))