python packages cleanup, add some missing deps
[openwrt/svn-archive/archive.git] / lang / pypcap / Makefile
index 23d6645e692fb5687a3128fc763433090a0dca1b..aa3c0e1975eacc6578029a732fbdfdd842c24430 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-pcap
   SUBMENU:=Python
@@ -38,6 +35,7 @@ define PyPackage/python-pcap/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                PCAP_HOME="$(STAGING_DIR)/usr" \