ettercap: Fix parallel build
[openwrt/svn-archive/archive.git] / lang / pypcap / Makefile
index 87a552a9fead9dca943388994690b500fdfd5c05..ecc0df5a1d14b7f07ac843aa50935652b2cb9608 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,7 +18,7 @@ PKG_MD5SUM:=034c3cbbfa81aa19e8f685b767c65764
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/python-pcap
   SUBMENU:=Python
@@ -34,6 +33,8 @@ define PyPackage/python-pcap/filespec
 +|$(PYTHON_PKG_DIR)/pcap.so
 endef
 
+TARGET_CFLAGS += -DHAVE_PCAP_FILE=1
+
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \