ettercap: Fix parallel build
[openwrt/svn-archive/archive.git] / lang / pypcap / Makefile
index aa3c0e1975eacc6578029a732fbdfdd842c24430..ecc0df5a1d14b7f07ac843aa50935652b2cb9608 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,7 +18,7 @@ PKG_MD5SUM:=034c3cbbfa81aa19e8f685b767c65764
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/python-pcap
   SUBMENU:=Python
@@ -27,13 +26,15 @@ define Package/python-pcap
   CATEGORY:=Languages
   TITLE:=Python interface to lipcap
   URL:=http://code.google.com/p/pypcap/
-  DEPENDS:=python-core +libpcap
+  DEPENDS:=+python-mini +libpcap
 endef
 
 define PyPackage/python-pcap/filespec
 +|$(PYTHON_PKG_DIR)/pcap.so
 endef
 
+TARGET_CFLAGS += -DHAVE_PCAP_FILE=1
+
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \