nuke $Id$ in /packages as well
[openwrt/svn-archive/archive.git] / lang / pypcap / Makefile
index 23d6645e692fb5687a3128fc763433090a0dca1b..ed7d0281d78ef3069764d706c831f54013c9cb9f 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -20,9 +19,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-pcap
   SUBMENU:=Python
@@ -30,7 +26,7 @@ define Package/python-pcap
   CATEGORY:=Languages
   TITLE:=Python interface to lipcap
   URL:=http://code.google.com/p/pypcap/
-  DEPENDS:=python-core +libpcap
+  DEPENDS:=+python-mini +libpcap
 endef
 
 define PyPackage/python-pcap/filespec
@@ -38,6 +34,7 @@ define PyPackage/python-pcap/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                PCAP_HOME="$(STAGING_DIR)/usr" \