Update lft to 3.1 (#3631)
[openwrt/svn-archive/archive.git] / lang / pysqlite / Makefile
index bade7b3237e57b5ac376d7c0a59371e4eee60d19..b1629fbf5b6d28e90d57b822d5dd59b382d30cb7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,18 +15,22 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://initd.org/pub/software/pysqlite/releases/2.3/2.3.5/
 PKG_MD5SUM:=b4a185e936848370fcc1a5b17755b641
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-sqlite
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
  TITLE:=SQLite database adapter for Python
  URL:=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
- DEPENDS:= +libsqlite3
+ DEPENDS:=python-core +libsqlite3
 endef
 
 define Package/python-sqlite/description