better download url for imlib2
[openwrt/svn-archive/archive.git] / lang / pysqlite / Makefile
index 18507ea0d67cc2a97377202748f01681a7f44f10..e9431198efad770094c5149525e1bed92d92e9be 100644 (file)
@@ -15,22 +15,26 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://initd.org/pub/software/pysqlite/releases/2.3/2.3.5/
 PKG_MD5SUM:=b4a185e936848370fcc1a5b17755b641
+PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
-
-define PyPackage/pysqlite
- TITLE:=SQLite database adapter
- URL=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
- DEPENDS+= +libsqlite3
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
+endif
+
+define Package/python-sqlite
+ TITLE:=SQLite database adapter for Python
+ URL:=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
+ DEPENDS:= +libsqlite3
 endef
 
-define PyPackage/pysqlite/description
+define Package/python-sqlite/description
  This package contains an SQLite database adapter for the Python 
  programming language.
 endef
 
-define PyPackage/pysqlite/filespec
+define PyPackage/python-sqlite/filespec
 +|$(PYTHON_PKG_DIR)/pysqlite2
 -|$(PYTHON_PKG_DIR)/pysqlite2/test
 endef
@@ -41,4 +45,5 @@ define Build/Compile
        )
 endef
 
-$(eval $(call PyPackage,pysqlite))
+$(eval $(call PyPackage,python-sqlite))
+$(eval $(call BuildPackage,python-sqlite))