Update python-dbus to 0.83.0
[openwrt/svn-archive/archive.git] / lang / python-dbus / Makefile
index c8773d7561f96731754532923ce49c5750938079..30e7800097da33d9d2a4c4116ca58396d0647b6c 100644 (file)
@@ -1,29 +1,32 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dbus-python
 PKG_VERSION:=0.83.0
-PKG_RELEASE:=2
+PKG_RELEASE:=1
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus-python/
 PKG_MD5SUM:=562c78876219bf458d79a041af18293d
-PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
-PKG_INSTALL=1
 
 EXTRA_CFLAGS += \
        -I$(STAGING_DIR)/usr/lib/libintl/include \
        -I$(STAGING_DIR)/usr/lib/libiconv/include
 
 EXTRA_LDFLAGS += \
+       -Wl,-rpath=$(STAGING_DIR)/usr/lib \
        -L$(STAGING_DIR)/usr/lib/libintl/lib \
        -L$(STAGING_DIR)/usr/lib/libiconv/lib
 
@@ -33,7 +36,7 @@ define Package/dbus-python
   CATEGORY:=Languages
   TITLE:=Python bindings for dbus
   URL:=http://dbus.freedesktop.org/
-  DEPENDS:=python-core +libdbus-glib
+  DEPENDS:=+python +libdbus-glib
 endef
 
 define Package/dbus-python/description
@@ -41,23 +44,33 @@ define Package/dbus-python/description
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/dbus-1.0/dbus/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0/dbus/* \
+       $(INSTALL_DIR) $(1)/usr/include/dbus-1.0/dbus
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/dbus-1.0/dbus/* \
                $(1)/usr/include/dbus-1.0/dbus/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig
 endef
 
 define Package/dbus-python/install
-       $(INSTALL_DIR) $(1)/usr/lib/python2.5/site-packages/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/*.{py,so,a} \
-               $(1)/usr/lib/python2.5/site-packages/
-       $(INSTALL_DIR) $(1)/usr/lib/python2.5/site-packages/dbus/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/dbus/*.py \
-               $(1)/usr/lib/python2.5/site-packages/dbus/
-       $(INSTALL_DIR) $(1)/usr/lib/python2.5/site-packages/dbus/mainloop/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/dbus/mainloop/*.py \
-               $(1)/usr/lib/python2.5/site-packages/dbus/mainloop/
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/*.{py,so} \
+               $(1)$(PYTHON_PKG_DIR)
+
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/dbus
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/dbus/*.py \
+               $(1)$(PYTHON_PKG_DIR)/dbus
+
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/dbus/mainloop
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/dbus/mainloop/*.py \
+               $(1)$(PYTHON_PKG_DIR)/dbus/mainloop
+
 endef
 
 $(eval $(call BuildPackage,dbus-python))