[packages] lang/python fixes:
[openwrt/svn-archive/archive.git] / lang / python / Makefile
index 7115a75408816c0f83e8afdcb44cb32524bce0f5..7887857c7fa165b7818f112a2ecd186aa1e20db3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2007 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python
 PKG_VERSION:=2.5.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
@@ -69,18 +69,19 @@ endef
 define Package/python-doc
 $(call Package/python/Default)
  TITLE:=Python interactive documentation
+ DEPENDS+= python-core
 endef
 
 define Package/python-expat
 $(call Package/python/Default)
  TITLE:=Python support for expat
- DEPENDS+= +libexpat
+ DEPENDS+= python-core +libexpat
 endef
 
 define Package/python-openssl
 $(call Package/python/Default)
  TITLE:=Python support for OpenSSL
- DEPENDS+= +libopenssl
+ DEPENDS+= python-core +libopenssl
 endef
 
 
@@ -135,35 +136,28 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/mk
+       $(INSTALL_DIR) $(1)/mk $(2)/bin $(1)/usr/bin $(1)/usr/include $(1)/usr/lib
        $(INSTALL_DATA) ./python-package.mk $(1)/mk/
-       mkdir -p $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/hostpython $(1)/usr/bin/
        ln -sf hostpython $(1)/usr/bin/python
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
+       ln -sf $(STAGING_DIR)/usr/bin/hostpython $(2)/bin/
+       ln -sf $(STAGING_DIR)/usr/bin/python $(2)/bin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
                $(1)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION) \
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION) \
+               $(PKG_BUILD_DIR)/libpython$(PYTHON_VERSION).a \
                $(1)/usr/lib/
-       $(CP)   $(PKG_BUILD_DIR)/libpython$(PYTHON_VERSION).a \
-               $(1)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(1)/usr/bin/hostpython \
-               $(1)/usr/bin/python \
-               $(1)/usr/include/python$(PYTHON_VERSION) \
-               $(1)/usr/lib/python$(PYTHON_VERSION) \
-               $(1)/usr/lib/libpython$(PYTHON_VERSION).a
 endef
 
 define PyPackage/python/filespec
 +|/usr/bin/python$(PYTHON_VERSION)
++|/usr/include/python$(PYTHON_VERSION)/pyconfig.h
 +|/usr/lib/python$(PYTHON_VERSION)
 -|/usr/lib/python$(PYTHON_VERSION)/bsddb/test
 -|/usr/lib/python$(PYTHON_VERSION)/config
++|/usr/lib/python$(PYTHON_VERSION)/config/Makefile
 -|/usr/lib/python$(PYTHON_VERSION)/ctypes/test
 -|/usr/lib/python$(PYTHON_VERSION)/distutils/command/wininst-*.exe
 -|/usr/lib/python$(PYTHON_VERSION)/distutils/tests
@@ -251,7 +245,7 @@ define PyPackage/python-mini/install
        ln -sf python$(PYTHON_VERSION) $(1)/usr/bin/python
 endef
 
-define PyPackage/python-pydoc/filespec
+define PyPackage/python-doc/filespec
 +|/usr/lib/python$(PYTHON_VERSION)/pydoc.py
 endef