[packages] python: add dependency on python-core to subpackages
[openwrt/svn-archive/archive.git] / lang / python / Makefile
index c4d63d6084cd8918b17b4e48d777f3fe370f0df7..a2394ca5dc13d40ddd1aaf2f3cf3e7f7e18486dd 100644 (file)
@@ -69,18 +69,19 @@ endef
 define Package/python-doc
 $(call Package/python/Default)
  TITLE:=Python interactive documentation
+ DEPENDS+= python-core
 endef
 
 define Package/python-expat
 $(call Package/python/Default)
  TITLE:=Python support for expat
- DEPENDS+= +libexpat
+ DEPENDS+= python-core +libexpat
 endef
 
 define Package/python-openssl
 $(call Package/python/Default)
  TITLE:=Python support for OpenSSL
- DEPENDS+= +libopenssl
+ DEPENDS+= python-core +libopenssl
 endef