added yaml implementation in c and modify pyyaml to make use of it
[openwrt/svn-archive/archive.git] / lang / pyyaml / Makefile
index c130480749a301e214be5842385718c28b3ea73c..7f7db7a6b984652e0c231810ceefe1d925ec3338 100644 (file)
@@ -25,7 +25,7 @@ define Package/pyyaml
   CATEGORY:=Languages
   TITLE:=pyyaml
   URL:=http://pyyaml.org
-  DEPENDS:=python-core
+  DEPENDS:=python-core +libyaml
 endef
 
 define Package/pyyaml/description
@@ -33,7 +33,7 @@ define Package/pyyaml/description
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+       $(call Build/Compile/PyMod,,--with-libyaml install --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Package/pyyaml/install