Fix the RequireCommand macro
[openwrt/svn-archive/archive.git] / lang / sablevm-classpath / Makefile
index 80beb53..ba344ec 100644 (file)
@@ -89,6 +89,8 @@ $(eval $(call BuildPackage,libsablevm-classpath))
 $(eval $(call BuildPackage,sablevm-classpath-full))
 $(eval $(call BuildPackage,sablevm-classpath-mini))
 
-$(eval $(call RequireCommand,jikes jikes-sablevm sablevm fastjar, \
-        libsablevm-classpath require jikes jikes-sablevm sablevm fastjar to compile. \
-))
+$(foreach command, jikes jikes-sablevm sablevm fastjar, \
+  $(eval $(RequireCommand,$(command), \
+   libsablevm-classpath requires $(command) to compile. \
+  )) \
+)