prevent procps from looking for ncurses on the host system
[openwrt/svn-archive/archive.git] / lang / sablevm / Makefile
index 170bf95332acd61c018f2b6602c51982ef83ae7f..3b80eaf9439e755f72994d468955e80e5af0db09 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=sablevm
 PKG_VERSION:=1.13
 PKG_RELEASE:=1
-PKG_MD5SUM:=d5828200032bfe921dd43e450931e38c
 
-PKG_SOURCE_URL:=http://sablevm.org/download/release/$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://sablevm.org/download/release/$(PKG_VERSION)/
+PKG_MD5SUM:=d5828200032bfe921dd43e450931e38c
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -27,32 +27,33 @@ define Package/sablevm
   CATEGORY:=Languages
   DEPENDS:=+libffi-sable +libltdl +libpopt +libpthread +zlib
   TITLE:=A Java Virtual Machine (JVM) implementation
-  DESCRIPTION:=SableVM is a robust, extremely portable, efficient, and specifications-\\\
-       -compliant Java virtual machine that aims to be easy to maintain and to\\\
+  DESCRIPTION:=\
+       SableVM is a robust, extremely portable, efficient, and specifications-\\\
+       -compliant Java virtual machine that aims to be easy to maintain and to \\\
        extend. It features a state-of-the-art and efficient interpreter engine.\\\
-       Its source code is very accessible and easy to understand. It also has\\\
-       many robustness features that have been the object of careful design. \\\
+       Its source code is very accessible and easy to understand. It also has \\\
+       many robustness features that have been the object of careful design.
   URL:=http://sablevm.org/
 endef
 
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-               --disable-static, LDFLAGS="-L$(STAGING_DIR)/usr/lib -lffi -lltdl -lpopt -lz")
+       $(call Build/Configure/Default, \
+               , \
+               LIBS="-lffi -lltdl -lpopt -lz" \
+       )
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/sablevm/install
-       install -m0755 -d $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/{java-,}sablevm $(1)/usr/bin/
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsablevm-*.so $(1)/usr/lib/
 endef