[package] update tcl to 8.5.8, clean-up makefile, use PKG_INSTALL, patch from Raphael...
[openwrt/svn-archive/archive.git] / lang / tcl / Makefile
index 91d676243d8fe5c754d1955cf0245652ffba2311..6e736c6d504ae1cdc949ce5f61b483fba17834c2 100644 (file)
@@ -1,21 +1,25 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcl
-PKG_VERSION:=8.4.19
+PKG_VERSION:=8.5.8
 PKG_RELEASE:=1
 
-PKG_SOURCE:=tcl$(PKG_VERSION)-src.tar.gz
+PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION)-src.tar.gz
 PKG_SOURCE_URL:=@SF/tcl
-PKG_MD5SUM:=ade2c033a7b545ee108f3fdfeb629fcf
+PKG_MD5SUM:=7f123e53b3daaaba2478d3af5a0752e3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)
 
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tcl
@@ -26,41 +30,35 @@ define Package/tcl
 endef
 
 define Package/tcl/description
-       TCL Scripting Language
+Tcl (Tool Command Language) is a very powerful but easy to learn dynamic
+programming language, suitable for a very wide range of uses, including web and
+desktop applications, networking, administration, testing and many more. Open
+source and business-friendly, Tcl is a mature yet evolving language that is truly
+cross platform, easily deployed and highly extensible.
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR)/unix; \
-       autoconf configure.in > configure; \
-       sed -i.bak "s/relid'/relid/" configure; \
-       $(TARGET_CONFIGURE_OPTS) \
-       ./configure \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --prefix=/usr \
-               --enable-gcc \
-               --enable-threads \
-               --disable-nls \
-       )
-endef
+CONFIGURE_PATH := unix
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/unix \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_VARS += \
+       tcl_cv_strtod_unbroken=ok
+
+CONFIGURE_ARGS += \
+       --enable-threads
+
+MAKE_PATH := unix
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtcl*.{a,so*} $(1)/usr/lib/
 endef
 
-
 define Package/tcl/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so $(1)/usr/lib
+
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
 endef