[packages] weechat: need to link against libdl, fixes compilation on backfire
[openwrt/svn-archive/archive.git] / lang / telepathy-python / Makefile
index 028505610c87f2e1eafa8a4fb960f7ff2b720e5f..436ea67843e02aa5abbe7307e68a8c1dbc9d534a 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,7 +15,7 @@ PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
 PKG_MD5SUM:=594a66a70764052e30df9428b5be52b2
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/telepathy-python
   SUBMENU:=Python
@@ -42,8 +41,9 @@ define Package/telepathy-python/install
            $(1)$(PYTHON_PKG_DIR)
 endef
 
-$(eval $(call BuildPackage,telepathy-python))
-
 $(eval $(call RequireCommand,xsltproc, \
        $(PKG_NAME) requires xsltproc installed on the host-system. \
 ))
+
+$(eval $(call BuildPackage,telepathy-python))
+