[packages] Require* calls must now be placed before BuildPackage calls
[openwrt/svn-archive/archive.git] / lang / telepathy-python / Makefile
index 25990054b2490d8d5f0786e0f8f6f39b1776e04e..6a7a1745caf873d2d4bbba7bc72a66bd104f7120 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telepathy-python
-PKG_VERSION:=0.15.0
+PKG_VERSION:=0.15.3
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
-PKG_MD5SUM:=678a28e3b7d06f75940beec28130d9a5
+PKG_MD5SUM:=594a66a70764052e30df9428b5be52b2
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 define Package/telepathy-python
   SUBMENU:=Python
@@ -22,24 +23,27 @@ define Package/telepathy-python
   CATEGORY:=Languages
   TITLE:=telepathy-python
   URL:=http://telepathy.freedesktop.org
-  DEPENDS:=python-core
+  DEPENDS:=+python-mini +dbus-python
 endef
 
 define Package/telepathy-python/description
-  telepathy- python bingings
+  telepathy python bindings
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) /usr/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Package/telepathy-python/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
 endef
 
-$(eval $(call BuildPackage,telepathy-python))
-
 $(eval $(call RequireCommand,xsltproc, \
        $(PKG_NAME) requires xsltproc installed on the host-system. \
 ))
+
+$(eval $(call BuildPackage,telepathy-python))
+