Update telepathy-python to 0.15.3
[openwrt/svn-archive/archive.git] / lang / telepathy-python / Makefile
index d42d22e9271a8c60b972fb9319c689562bfb1167..c4dae7541602e919a214d3cd119af0d451a22a28 100644 (file)
@@ -9,11 +9,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telepathy-python
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telepathy-python
-PKG_VERSION:=0.15.0
+PKG_VERSION:=0.15.3
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
-PKG_MD5SUM:=678a28e3b7d06f75940beec28130d9a5
+PKG_MD5SUM:=594a66a70764052e30df9428b5be52b2
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
@@ -24,7 +24,7 @@ define Package/telepathy-python
   CATEGORY:=Languages
   TITLE:=telepathy-python
   URL:=http://telepathy.freedesktop.org
   CATEGORY:=Languages
   TITLE:=telepathy-python
   URL:=http://telepathy.freedesktop.org
-  DEPENDS:=python-core
+  DEPENDS:=python-core +dbus-python
 endef
 
 define Package/telepathy-python/description
 endef
 
 define Package/telepathy-python/description
@@ -36,9 +36,10 @@ define Build/Compile
 endef
 
 define Package/telepathy-python/install
 endef
 
 define Package/telepathy-python/install
-       #FIXME: Only copy required files
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
 endef
 
 $(eval $(call BuildPackage,telepathy-python))
 endef
 
 $(eval $(call BuildPackage,telepathy-python))