Update telepathy-python to 0.15.3
[openwrt/svn-archive/archive.git] / lang / telepathy-python / Makefile
index d9fc4270886225b81aaf3169a88b0c2459f485af..c4dae7541602e919a214d3cd119af0d451a22a28 100644 (file)
@@ -4,16 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telepathy-python
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telepathy-python
-PKG_VERSION:=0.15.0
+PKG_VERSION:=0.15.3
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://telepathy.freedesktop.org/releases/telepathy-python/
+PKG_MD5SUM:=594a66a70764052e30df9428b5be52b2
 
 include $(INCLUDE_DIR)/package.mk
 
 include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
 define Package/telepathy-python
   SUBMENU:=Python
 
 define Package/telepathy-python
   SUBMENU:=Python
@@ -21,20 +24,22 @@ define Package/telepathy-python
   CATEGORY:=Languages
   TITLE:=telepathy-python
   URL:=http://telepathy.freedesktop.org
   CATEGORY:=Languages
   TITLE:=telepathy-python
   URL:=http://telepathy.freedesktop.org
-  DEPENDS:=python-core
+  DEPENDS:=python-core +dbus-python
 endef
 
 define Package/telepathy-python/description
 endef
 
 define Package/telepathy-python/description
-  telepathy- python bingings
+  telepathy python bingings
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) /usr/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Package/telepathy-python/install
 endef
 
 define Package/telepathy-python/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
 endef
 
 $(eval $(call BuildPackage,telepathy-python))
 endef
 
 $(eval $(call BuildPackage,telepathy-python))