[patchteam] twisted fix for installing zope
[openwrt/svn-archive/archive.git] / lang / twisted / Makefile
index 4acaac49e34ed2a4076963312dc9ada06d39a70e..2dd39421ffe42713b6159b938c4506fd06a2e29f 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -20,14 +19,14 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/Twisted-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/twisted/default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   URL:=http://twistedmatrix.com/
-  DEPENDS:=python-core
+  DEPENDS:=+python-mini
 endef
 
 define Package/twisted/default/description
@@ -219,11 +218,17 @@ define Build/Compile
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
                TWISTED_SUBPROJECTS="$(TWISTED_SUBPROJECTS)" \
+               PYTHONPATH="$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)" \
        )
        $(call Build/Compile/PyMod,zope.interface-$(ZOPE_IF_VER), \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
+               PYTHONPATH="$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)" \
        )
        $(SED) 's,#!$(PYTHON),#!/usr/bin/python,' $(PKG_INSTALL_DIR)/usr/bin/*
+
+       $(CP) -a \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/zope.interface-*.egg/zope \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call PyPackage,twisted))