adding etk (toolkit based on efl)
[openwrt/svn-archive/archive.git] / lang / twisted / Makefile
index 799e826ff93f917bb1505afcf963de32f77633cd..4acaac49e34ed2a4076963312dc9ada06d39a70e 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,15 +21,13 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
-endif
 
 define Package/twisted/default
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  DEPENDS:=python-core
   URL:=http://twistedmatrix.com/
+  DEPENDS:=python-core
 endef
 
 define Package/twisted/default/description
@@ -217,6 +215,7 @@ define PyPackage/zope-interface/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
                TWISTED_SUBPROJECTS="$(TWISTED_SUBPROJECTS)" \