[packages_10.03.1] collectd: backport r29404
[openwrt/svn-archive/archive.git] / lang / xapian-bindings / Makefile
index a6c97a97262b4c8b85d968089bef96a7f6c85a32..85cbba0924c6f5f4acb3afd37b1be81ac00e7882 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -14,10 +13,12 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://oligarchy.co.uk/xapian/$(PKG_VERSION)
+PKG_MD5SUM:=a80e51f4971d7505abcc0bdde912266b
+
 PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 PKG_INSTALL=1
 
@@ -26,17 +27,19 @@ define Package/python-xapian
   CATEGORY:=Languages
   SUBMENU:=Python
   TITLE:=xapian python bindings
-  URL:=http://oligarchy.co.uk/xapian/
-  DEPENDS:=python +libxapian
+  URL:=http://xapian.org/
+  DEPENDS:=+python-mini +libxapian
 endef
 
-define Build/Configure
-  $(call Build/Configure/Default, --with-python)
-endef
+CONFIGURE_ARGS+= \
+       --with-python \
+
+CONFIGURE_VARS+= \
+       PYTHON_LIB="$(PYTHON_PKG_DIR)" \
 
 define Package/python-xapian/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
-       $(CP) $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* $(1)$(PYTHON_PKG_DIR)
+       $(CP) $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* $(1)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call BuildPackage,python-xapian))