xkbdata: Add missing dependency to xkbcomp
[openwrt/svn-archive/archive.git] / lang / yapsnmp / Makefile
index 651337dc59d05222277acd237604a31fbde7845e..12317ceebacb0c032067dfe6656586aec0cf7cf5 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,16 +15,23 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=8a3e9a5b814388d7907c639105cb2365
 
+PKG_BUILD_DEPENDS:=python
+
+PKG_FIXUP = libtool
+
 include $(INCLUDE_DIR)/package.mk
-include ../python/python-package.mk
+$(call include_mk, python-package.mk)
 
-define PyPackage/python-yapsnmp
- TITLE:=Python interface to Net-SNMP
- URL:=http://yapsnmp.sourceforge.net/
- DEPENDS+= +libnetsnmp
+define Package/python-yapsnmp
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Python interface to Net-SNMP
+  URL:=http://yapsnmp.sourceforge.net/
+  DEPENDS:=+python-mini +libnetsnmp
 endef
 
-define PyPackage/python-yapsnmp/description
+define Package/python-yapsnmp/description
  This package contains a Python SNMP module based on the net-snmp (formerly 
  known as ucd-snmp) library. It's composed of a low level interface to the 
  library, created using SWIG, and a higher level python module removing all 
@@ -47,18 +53,14 @@ CONFIGURE_VARS += \
        ac_cv_file__usr_include_net_snmp_library="yes" \
        ac_cv_prog_SWIG="echo MISSING SWIG" \
 
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INCLUDES="-I$(PYTHON_INC_DIR)" \
                SNMPINCDIR="$(STAGING_DIR)/usr/include/net-snmp/library" \
                all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
 
 $(eval $(call PyPackage,python-yapsnmp))
+$(eval $(call BuildPackage,python-yapsnmp))