xkbdata: Add missing dependency to xkbcomp
[openwrt/svn-archive/archive.git] / lang / yapsnmp / Makefile
index ce597c1c1101edcdc2a4f3c523fd0e5e0aabebd5..12317ceebacb0c032067dfe6656586aec0cf7cf5 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -21,10 +20,7 @@ PKG_BUILD_DEPENDS:=python
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
+$(call include_mk, python-package.mk)
 
 define Package/python-yapsnmp
   SUBMENU:=Python
@@ -32,7 +28,7 @@ define Package/python-yapsnmp
   CATEGORY:=Languages
   TITLE:=Python interface to Net-SNMP
   URL:=http://yapsnmp.sourceforge.net/
-  DEPENDS:=python-core +libnetsnmp
+  DEPENDS:=+python-mini +libnetsnmp
 endef
 
 define Package/python-yapsnmp/description
@@ -58,6 +54,7 @@ CONFIGURE_VARS += \
        ac_cv_prog_SWIG="echo MISSING SWIG" \
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INCLUDES="-I$(PYTHON_INC_DIR)" \
                SNMPINCDIR="$(STAGING_DIR)/usr/include/net-snmp/library" \